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INTRODUCTION

The Emutel Rack

The Emutel Rack simulates a Central Office switch.
Depending on which cards are inserted the switch can
emulate basic rate ISDN, primary rate ISDN, V5.1,
V5.2, analogue telephone networks.
A call on any bearer channel on any interface can be
connected to any other bearer channel on any other
interface.
The setup and configuration of the EMUTEL is
achieved via a Windows application program. Also
available as a software option is a protocol analyser.

The manual

This manual outlines how the Emutel Rack should be
set up and how the network and terminal equipment is
connected.
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ISDN Connections

The Emutel Rack can simulate, basic rate ISDN on
either an S0 or U interface, analogue, primary rate
ISDN on either E1 (S2m) or T1, V5.1 and V5.2 on
up to 8 E1 (S2m) links.

Terminal Port

A V.24 port is provided allowing the connection of
a PC for configuration and analysis of the unit.

Ethernet Port

An IEEE 802.3 Ethernet port is provided for
connection to a local area network.

Modem Port

LED’s indicate (1) network present, (2) network
activity.
A modem port is provided to allow the Emutel
Rack to be controlled remotely.
LED’s indicate that the modem is (1) off hook, (2)
ringing.

Power

The Emutel Rack is available in mains powered
and dc powered versions. The mains version
accepts a voltage of 110-240V AC (50-60Hz). The
dc version accepts a voltage of –36V to –72V DC
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Introduction

The Emutel Rack consists of a chassis, mains or dc
power supply, controller card and up to 2 line cards.
The controller card must be fitted in the first slot.
There are no user serviceable parts inside the Emutel
Rack. Removal of the case by unauthorised staff will
result in a void of warranty.

Figure 1
Chassis

Mains Power supply

Emutel Rack front and rear panels

The chassis consists of a metal case and a back plane
to accept the controller card, line cards and power
supply.
The mains power supply has a universal input suitable
for 110V-240Vac/50-60Hz. Connection to any other
source may result in the unit failing to comply with
safety requirements.
Power should be supplied via an IEC mains lead
(supplied).
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The power supply must have a protective ground
(earth). If not the mains filter will force the metal
case to a voltage equal to half the mains supply
voltage.
DC power supply

The dc power supply has 2 input connectors. Both
accept a voltage of –36V to –72V. Power can be
connected to either or both input connectors.
NB the 0V connections on both connectors are
common and are connected to the case.
The 0V connection should be connected to earth.

Figure 2
Controller card

Emutel Rack controller card

The controller card can feature 2 primary rate ports, 2
PC Card slots, modem, LAN port, terminal port and
LED’s.
The terminal port is a V.24 compatible control port to
which a PC running the application provided could be
connected.
The LAN port is an IEEE 802.3 compatible Ethernet
port.
It allows the Emutel Rack to be controlled remotely
via Telnet. Software upgrades are possible via FTP.
The Line port is the modem port. This is not enabled
for this product.
Port 1 and port 2 are the
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Pin-outs of the terminal, Ethernet, modem and PRI
ports are given in an appendix.
LED’s indicate power and alarm.
For each primary rate port the P LED is on when both
physical link layer and data link layer are active. It
flashes when only the physical link is active. The B
LED is on when any B channel is in use.
For the Ethernet port the P LED indicates network
present and the B LED indicates network activity.
For the modem port the P LED is on for off-hook and
flashing for ringing. The B LED indicates data
transfer.

Figure 3
card
U and S cards

EMUTEL VIRTUOSO U card and S

The U and S cards feature 8 Basic Rate Ports and
LED’s.
Ports 1-8 are BRI 1-8 if fitted in the first line card slot
or BRI 9-16 if fitted in the second line card slot.
Pin-outs of the BRI interfaces are given in an
appendix.
LED’s indicate power and alarm.
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For each port the P LED is on when both physical link
layer and data link layer are active. It flashes when
only the physical link is active. The B LED is on when
any B channel is in use.

Restoring default settings

When the unit is first switched on the terminal port
will default to 19200-baud, no parity, 8 data bits and 2
stop bits and will search for a <ctrl-c> being
transmitted to the EMUTEL VIRTUOSO. If this
occurs the EMUTEL VIRTUOSO will restore the
factory defaults otherwise it will use the stored
settings.
If a setting has been changed and the EMUTEL
VIRTUOSO ceases to operate, powering up the
EMUTEL VIRTUOSO, while holding down <ctrl-c>
for the first 20 seconds will restore a working
configuration to the EMUTEL VIRTUOSO.
The default settings are listed in an appendix.

Figure 4
V5CARD

EMUTEL VIRTUOSO V5 card

The V5card features 8 E1 Ports and LED’s.
Pin-outs of the PRI interfaces are given in appendix II.
LED’s indicate power and alarm.
Chapter 3

8

QUICK REFERENCE QUIDE

For each port the P LED is on when both physical link
layer are active. It flashes when only the physical link
is active. The D LED is on when any of the data link
layers are active.
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Unpack the Emutel Virtuoso

Take an Inventory

First unpack the Virtuoso and check for signs of
damage in transit. If the unit or packaging is damaged
this should be reported immediately to Arca
Technologies.
Assuming there is no damage, take an inventory of the
parts supplied. Check that the items ordered were
actually received. The list below should be of help in
identifying each part.
♦
♦
♦
♦
♦

Connect to a PC or terminal

Virtuoso V5 Local Exchange Simulator
Cables for ISDN - RJ45-RJ45 (4 off)
Mains Cable
Terminal Cable DB9-DB9 (1 off)
This Manual

Plug the terminal cable into the terminal connector on
the controller card at the front of the unit and connect
to a PC.
(Virtuoso default terminal settings are ANSI terminal
compatible, 115200-baud, 8 data bits, no parity, 2 stop
bits).

Connect power

Plug the power cable into the rear of the unit and
switch on
(Virtuoso will work on 110V or 240V mains supply
without adjustment).

Connect terminal equipment

E1 links can be connected to the Emutel Virtuoso
using the RJ-45 cables provided. For V5.2 the Primary
and Secondary links port is defined in the
configuration file.
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Software installation

Installation of software

Digital Engineering Ltd Folder contents

The Emutel Virtuoso is controlled using the Emutel
Windows application. The Emutel Windows
application is capable of running on a PC with
windows 95/98/2000 and NT operating systems
The Emutel Windows application and V5analyser can
be installed using the CD provided. Selecting DISK1
from the DISK IMAGES file
Select the setup icon and follow the on screen
instructions Once completed the software will installed
on your local drive c:\programme files\Digital
Engineering Ltd.
This folder contains.
- Emutel Windows Application (v5rack)
The V5RACK is used to control the configuration and
display the current state of each port of the Emutel
Virtuoso.
- V5Analyser
The V5Analyser displays to the user full decoding of
the V5 protocol and ISDN protocol as well as
providing statistical analysis
-V51config.V52
The V51CONFIG file is a template for the text file
used to configure the EMUTEL VIRTUOSO to the
customers requirement for a V5.1 interface
-V52config.V52
The V52CONFIG file is a template for the text file
used to configure the EMUTEL VIRTUOSO to the
customers requirement for a V5.2 interface
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Introduction to the windows
application

Before using the Emutel Virtuoso you must set the
configuration of the Emutel Virtuoso to match that of
the corresponding Access Network. This done using
the Emutel Graphical User Interface shown as a
DigApp icon in the installed directory.
To connect the V5RACK to the Emutel Virtuoso use
the RS-232 cable provided. Connect the RS-232 cable
to the nine-way D-type connector situated at the front
of the Controller card.
Using the V5RACK menu set the RS-232 port settings
as shown below.

From the menu select Comport -> Connect. After a
short time lag, the V5RACK application will display
the current configuration of the Emutel Virtuoso.
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Changing the configuration

Connecting the V5analyser

To change the configuration the user need to generate
a new text file that meets their configuration
requirements (Text file format). Once the text file has
been generated the user can upload the configuration
to the unit. Select File -> Open. Choose the required
file to be uploaded to the Emutel Virtuoso. If the file
has been uploaded correctly the new ports displayed
on the screen will match the text file.
Once configuration has been completed the User
should restart the system Interface -> Restart Link or
by power cycling the unit. On restart the Unit will start
up with the Access Network.
A full description of the V5RACK functions is given
in section
Using the V5RACK menu select Analyser ->
Analyser -> analyser on. This will enable the Emutel
Virtuoso to transmit Analyser message.
From the Digital Engineering Directory open the
V5Analyser.
To connect the V5Analyser click the mouse button on
the icon shown below.

A successful connection will display the following
window.

Analyser messages will now be displayed.
Further information on the analyser menus can be
found
Conclusion

The user can now use the Emutel Virtuoso Local
Exchange Simulator from this set of instruction to
ensure that their equipment is set up correctly. More
detailed explanation of the user function on the
Chapter 5
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V5RACK and V5Anayser are detailed in later
chapters.
Telephone numbers for the Emutel Virtuoso are
supplied in Appendix 1.
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Introduction to fault finding

Unable to connect to the
Emutel Virtuoso using the
V5RACK

Configuration errors

Due to the nature of the V5 protocol care must be
taken when changing the configuration of the unit.
Here are some examples of operator error that may
help eliminate initial problems.
This problem occurs often; first the user should ensure
that the port settings are correct. If the problem persists
further then:
- Using a Dumb terminal, such as
HyperTerminal set the Baud rate to 19200.
- Power cycle the unit.
- On power up press CTRL + C.
- Reset should be continuously displayed on the
screen.
- Release the Keys until the Digital Engineering
copyright screen appears.
- Press Enter and then Enter into the Hardware
setup menu.
- Using the Space bar change the Baud Rate of
the unit to 115200 and press ESC.
- Closed down the Dumb terminal and try to
connect to the unit again
After uploading a new configuration file to the Emutel
VIRTUOSO. If the change in configuration on restart
have not taken place, power cycle the unit and
reconnect to the Emutel VIRTUOSO using the
Emurack application. If the configuration changes
have not taken place then the problem have occurred
due to;
1. Incorrect configuration for version. The user
may be trying to upload a configuration that
does not match the allowed configuration of the
unit. Check with your local dealer or purchaser
to detail the configuration limitations set at
time of purchase.
2. Incorrect configuration. The text file that is
used to generate the configuration file has
errors in it. This could be due to missing text,
incorrect text, invalid configuration text. Check
the text file for and mistakes such as duplicated
layer3 addresses on the same system.
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File -> Save

This enables the user to save the units current
configuration to file.

File -> Open

Opens a configuration file and uploads it to the Emutel
Virtuoso. Configuration files are of type *.V52

Interface -> Restart Link

Used to restart the E1 Link. Commonly used after the
unit has been reconfigured to update the configuration
on the unit.

Interface -> Request Link config

Analyser -> analyser

Analyser -> TCP/IP Settings
View -> System Messages

View -> Racks -> Data links

View -> Racks -> E1 Racks

This function enables the user to view the current Link
configuration of the Emutel Virtuoso
Enables the Emutel Virtuoso to send analyser
messages to the V5protocol analyser.
Not enabled on this version of software
Enables the user to view all the messages and decoding
that are being passed too and from the Emutel
Windows application to the Emutel Virtuoso
The Data links rack displays the V5 Protocols
currently being used, such as BCC, PSTN and CTRL

The E1 rack will display the current links that are
currently configured at the Local Exchange.
From this rack the user can extract and request various
information about the E1 Link status.

Hovering over the specified E1 link and using the right
mouse button will display another menu.
Hidden Menu
Blocking -> immediate
The Local Exchange will immediately block the link.
Blocking -> Deferred
The Local Exchange will not block the link until all the
current B-channels that are in use are returned to the
null state
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Blocking -> Non-deferred
The Local Exchange will block the link regardless of
whether any B-channels are in the active state.
Blocking -> Unblock
The Emutel Virtuoso Local Exchange simulator will
send and Unblock Request the V5 Access Network for
the required E1 link.
ID Request
This messages will invoke the Emutel Virtuoso to send
an id request out on that particular Link.

Info Request
The info request message will ask the Emutel Virtuoso
return all the relevant port information. This
information will be displayed in the systems messages
window after API_LINK_INFO_CO.
Hovering over the Link with the mouse pointer will
encapsulate a windows displaying all the relevant
information for that E1 link ( as below )

Graphical Information
The Graphic that represent the link also translate
information to the user.
The LED at the centre of the Icon will turn Red when
the link is active.
When the Link is blocked the coloured bar at the
bottom of the link is Red when the Link is unblocked
this will change colour to Green.
The number that is displayed in this Bar represents the
Layer3 address of this Link.
View -> Racks -> ISDN Racks

Each ISDN rack will display 15 Basic Rate Interfaces
within this graphical feature the user can send and
extract a variety of information about that port.
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Hovering over the required Basic Rate Interface with
the mouse pointer the user can right click on the icon
to reveal a hidden menu
Hidden Menu
Block Port
This command initiates the Emutel Virtuoso to send a
port block request to the Access Network top block
that particular port. The port will then enter the OUT
OF SERVICE state.
Unblock Port
The Unblock Port command enables the Emutel
Virtuoso to request that a particular port be unblocked
to the Access Network. If this is successful the port
will enter the AN1 NULL state.
Get Port Info
The Get port Info command enables the user to gather
all the information about that port that is currently
available.
Port Status -> Activate Access
Port Status -> De-activate Access
Port Status -> Unblock Request
Port Status -> Block Indication
Port Status -> Activate Loopback
Not Applicable to this Version of code
Port Status -> Activate Partially
Not Applicable to this version of code
Port Status -> De activate T
Not Applicable to this version of code
Hovering over the Port icon with the mouse pointer
will encapsulate a window displaying all the relevant
information for that BRI (as below)
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This displays to the user the
-BRI number
-The port Layer3 address
-B1 timeslot (V5.1 only)
-B2 timeslot (V5.2 only)
Graphical Information
The Graphic that represent the Basic Rate Interface
also translate information to the user.
The Graphic has four LED`S :
P-LED – When the P LED is red this means that the
Physical layer is active for this particular BRI.
D-LED- When the D LED is red this means that the
D-channel for this particular BRI is active.
B1-LED- When the B1 LED is red this means that the
B1-channel for this particular BRI is currently in use.
B2-LED- When the B2 LED is red this means that the
B2-channel for this particular BRI is currently in use.
When the BRI is blocked the coloured bar at the
bottom of the link is Red when the BRI is unblocked
this will change colour to Green.
The number that is displayed in this bar represents the
Layer3 address of this Link.
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View -> Racks -> PSTN Racks

Each PSTN rack will display 30 PSTN ports, within
this graphical feature the user can send and extract a
variety of information about each port.

Hidden Menu
Block Port
This command initiates the Emutel Virtuoso to send a
port block request to the Access Network top block
that particular port. The port will then enter the OUT
OF SERVICE state.
Unblock Port
The Unblock Port command enables the Emutel
Virtuoso to request that a particular port be unblocked
to the Access Network. If this is successful the port
will enter the AN1 NULL state.
Get Port Info
The Get port Info command enables the user to gather
all the information about that port that is currently
available.
Hovering over the Port icon with the mouse pointer
will encapsulate a window displaying all the relevant
information for that PSTN port (as below)

PSTN: port number.
L3: Port Layer3 address
TS: allocated timeslot number (V5.1 only)
Graphical Information
The Graphic that represent the Basic Rate Interface
also translate information to the user.
The Graphic has four LED`S :
RG LED. The Ring LED will flash red when the
PSTN port at the Access Network is ringing.
HK LED. The Hook LED will illuminate red when the
PSTN port at the Access Network is off hook.
When the PSTN port is blocked the coloured bar at the
bottom of the link is Red when the PSTN port is
Chapter 7
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unblocked this will change colour to Green.
The number that is displayed in this bar represents the
Layer3 address of this Link.

Comport -> port settings

This function enables the user to set up the RS 232
port options. The options are displayed in the graphic
below. The fields should be filled in as shown on the
graphic below (except the comport number)

Comport -> Connect

Connects the Emutel Windows application to the
Emutel Virtuoso via a RS-232 link.

Comport -> Disconnect

V5rack information board

Disconnects the Emutel Windows application form the
Emutel Virtuoso

The V5 rack information board is located just under
the window menu. The function of the information
board is to make available to the user certain
information about the Emutel Virtuoso.
Hovering over each of the ports displays port
information on this board. The field parameters for this
information are supplied below.

First row field information
Interface

Displays the type of interface that is available
V5.1/V5.2 depending on options available at time of
purchase.
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Links

Analyser

Serial Number
Version
Date

The number of links that are available on user Emutel
Virtuoso
Enable the user to determine if the analyser has been
fitted to the Unit.
Displays to the User the Emutel Virtuoso serial number
This will display the Version number of the firmware.
Represents the date of the software version

Second row field information

Box1. This box will contain either of the messages
listed below.
Connected - The Emutel windows application is
connected to The Emutel Virtuoso via a RS-232
connection.
Disconnect- The unit is connected to nothing
Box2. This box will contain either of the messages
listed below.
Connected - The Emutel windows application is
connected to The V5analyser via a Winsock.
Disconnect- The V5analyser has not been detected or
is not connected to the application.
Box3 B1 timeslot will be displayed when hovering
over a port here.
Box4 B2 timeslot will be displayed when hovering
over a port here.
Third row field information
Box 1 Displays the current port state
Box 2 Displays the port Number
Box 3 Displays the Layer3 address of the Port
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The Emutel configuration file

The Emutel Windows application software will have
been supplied with two files in the directory called
v51config.v52 and v52config.v52.
These two files are simply text files that allow the user
to edit the configuration of the unit to match that of the
Access Network.
Below is an explanation to the text requirement of the
files.

[V51]

[V5.2]

Variant Id

Interface Id

Ctrl_lcc_id
pstn_lcc_id
bcc_lcc_id
link_lcc_id

[BRI PORTS]

BRI

l3_address

ds_lcc_id
( V5.2 only )
p_lcc_id
( V5.2 only )

On upload this indicates to the Emutel Virtuoso that
the configuration will be V5.1
On upload this indicates the Emutel Virtuoso that the
unit is V5.2
The user can change the variant Id to match the Access
Network. If the Variant Id does not match the AN
equipments Variant Id the interfaces will fail to start
up together.
The user can change the interface Id to match the
Access Network. If the Variant Id does not match the
AN equipments interface Id the interfaces will fail to
start up together.
This number represents the Logical C-channel Id. This
number is define at the Link configuration and will
determine the timeslot that Ctrl protocol is
implemented.
Due to the restriction of V5.1 these values should be
set to 1.
Informs the Emutel Virtuoso that the following
information represents the systems Basic Rate
Interfaces.
This text followed by a number represents the Basic
Rate port number.
Enables the user to set the Layer 3 address of the
desired port
This function enables the user to set the Logical Cchannel that ISDN D-type ( SAPI 0 calls )
This function enables the user to set the Logical Cchannel that ISDN P-type ( SAPI 16 calls )

Chapter 8

23

V5 ANALYSER OPTIONS

f_lcc_id
( V5.2 only )
Time_slot_B1
(V5.1 only )
Time_slot_B2
(V5.1 only )

[PSTN PORTS]

PSTN

l3_address

time_slot
( V5.1 only )

[E1 LINKS]

This function enables the user to set the Logical Cchannel that ISDN F-type ( SAPI 32 - 62 calls ).
This function enables the user to allocate the timeslot
value for the B1 channel.
This function enables the user to allocate the timeslot
value for the B2 channel.

Informs the Emutel Virtuoso that the following
information represents the systems PSTN ports
This text followed by a number represents the PSTN
port number.
Enables the user to set the Layer 3 address of the
desired port
This function enables the user to allocate the timeslot
value for the pstn port.

Informs the Emutel Virtuoso that the following
information represents the systems E1 links

LINK

This text followed by a number represents the Link
number.

Type

This function enables the user to set the Link to three
types
- PRIMARY_LINK
- SECONDARY_LINK
- NORMAL_LINK
- UNUSED_LINK
PRIMARY_LINK
Primary Link identifier to the V5 system. Each V5.2
system must have a Primary link defined.
SECONDARY_LINK
Secondary Link identifier to the V5 system. Each V5.2
system must have a Secondary Link defined.
NORMAL_LINK
The normal link defines any active link that is not
Primary or Secondary.
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UNUSED LINK
An unused link defines a link that is not to be used in
the new configuration.

l3_address

Each link must have a Layer 3 address

ts_16_type

The timeslot (ts) type for each communication channel
has three options.
- LOGICAL_TIMESLOT This value sets the
particular timeslot on that link to be a logical
C-channel.

ts_15_type
ts_31_type

Note

-

STANDBY_TIMESLOT This value sets the
particular timeslot on that link to be a standby
timeslot. Standby timeslots should only be
configured on the secondary link.

-

NORMAL_TIMESLOT This values set the
particular timeslot on that link to be a normal
Bearer Channel.

Each line must in a semi colon else upload to the Emutel Virtuoso
will be unsuccessful.
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FILE -> OPEN CAPTURE

FILE -> SAVE AS (ASCII )

Opens a previously saved binary capture. Previous traces
saved as a binary file will be of type *.CAP. The Open
Capture command will default to the Windows Desktop
directory.
Shortcut key (Ctrl + O)
The current trace will be saved as a text file (*.txt) and
can be retrieved using a simple text editor.
Shortcut key (Ctrl + S)

FILE -> SAVE AS ( Binary )

The current trace will be saved as a binary file (*.CAP ).
This file can only be retrieved using the V5Analsyer
software.

FILE -> Load Configuration

Loads in a saved configuration file, which can be applied
to a current trace.

FILE -> Save configuration

Writes the current configuration of the V5Analyser to file
for future use.

FILE -> Load Filter

Retrieves a previously stored filter for use on a saved file,
display file or the current history buffer.

FILE -> Save filter

Writes the current filter settings to file for retrieval at a
later date.

FILE -> Exit

Monitor -> Connection

Monitor -> Disconnection

Monitor -> Start Recording

Monitor -> Stop Recording

Exits the V5analyser application.
Shortcut key (Ctrl + X)

Enables the V5analsyer to receive analyser message from
the Emutel Graphical User interface. Ensure that analyser
is enabled in the Emutel application.
Shortcut key (Ctrl + C)
Stops the V5anlayser buffers receiving messages in the
history buffer.
Shortcut key (Ctrl + D)

Begins writing incoming analyser messages file. This
function can be use for long periods of testing where
the history buffer may not be big enough to hold all the
required messages.
Prevents further incoming messages from being
Chapter 9
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written to file.
Monitor -> Pause

Monitor -> Stop ( Play &
Record )
Monitor -> Clear History
Buffer

Stops the current display from scrolling and continues
writing analyser messages to the history buffer or file.
Stops recording to the file and prevents further
analyser messages being displayed.
When beginning a new trace it is important to ensure
that the history buffer is cleared. This avoids confusion
during analysis.

Monitor -> Display Led Panel

Displays the Link configuration using a graphical
display panel located in a small window above the
analyser message. These LED`s. graphically display
the links that are to be monitored and the direction
which the messages are being monitored.

Monitor -> Display Status Bar

Enables the bar beneath the analyser window. This
enables the user to view the Path and Name of the
current Record file and the current configuration file

2
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Analyzer

Displays the path of the capture file for the current
Analyser trace.

Search -> Find

Enables the user to search the current trace for a
particular string of text. The search window gives an
option to search file in required direction (up or down).
The search criteria can be set to be case sensitive.
Shortcut Key (Ctrl + F)

Search -> Next

The next command enables the user to search for the
required string of text again in the same direction as
defined in the original search. This operation can be
used repeatedly to search the whole file.
Shortcut Key (F3)

Search -> Previous

The previous command enables the user to search for
the required string of text as defined in the original
search in the opposite direction the original search
criteria. This operation can be used repeatedly to
search the whole file in this direction.
Shortcut Key (F2)

Markers ->

Go to marker 1

Moves the cursor line to a predefined first marker
point. Used in large traces to jump to the start of a
significant event.
Shortcut Key ( F5 )

Markers ->

Go to marker 2

Moves the cursor line to a predefined second marker
point. Used in large traces to jump to the end of a
significant event.
Shortcut Key ( F6 )

Markers -> Set marker 1

This function allows the user to mark the starting point
of a trace that may be a significant point of interest in a
large file. The user can find this part of text quickly
using the shortcut key F5.
Shortcut Key ( Ctrl + F5 )

Markers -> Set Marker

This function allows the user to mark the end point of
a trace ending the user interest in the trace. The user
can find this part of text quickly using the shortcut key
F6.
Shortcut Key ( Ctrl + F6 )

Tools -> triggers -> trigger

The trigger function can be used to begin a recording
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action

Tools -> triggers -> Layer 1
triggering event

Tools -> triggers -> Layer 2
triggering event

action to a file. The triggering function allows the user
to trigger on a particular event in Layer1, Layer2 and
Layer3. The triggering action allows this function to be
set up. Within this function the user can enable or
disable triggering, define the action to be taken i.e.
record to file. This function also enable the user to
define the size of the triggering file by selecting the
number of messages to be stored before the selected
event has occurred and the number of messages after
the selected event has occurred. This controls the size
of a trace and enables the user to look for a certain
event, which may occur in a bulk call test over a period
of time.

Enables to user to define the criteria for triggering a
record to file due to a particular Layer 1 event
occurring

Enables to user to define the criteria for triggering a
record to file due to a particular Layer 2 event
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occurring. This includes the direction of the message,
the protocol ( BCC,PSTN ISDN etc ) and the message.

Tools -> triggers -> Layer 3
triggering event

Enables the user to define the criteria for triggering a record
to file using three methods
1. Checking for a specific message
2. Checking for a specific pattern in layer 3
3. Using a combination of options 1 and 2 however
you must specify the ‘Logic’ between the trap (1)
and (2): the layer 3 trigger event is verified if trap
(1) and trap (2) are verified, or only if one of the trap
is verified.

1.Checking for a specific message
The data to trap is defined by a specific protocol
message (or ‘Any’), by a network direction (From ->
to; AN = Access Network & LE = Local exchange),
and by an L3 address entered in hexadecimal value (or
‘Any’).
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2.Checking for a specific pattern
This is especially useful when you are looking for a
sequence in signalling data. The data to trap is defined
with a specific pattern to find in layer 3 messages.
A pattern is a sequence of bytes. Enter the pattern as a
consecutive sequence of bytes (one byte per line) in
the area named "Bit pattern”: each byte is represented
by its 8 bits value (0 or 1 or “x” meta-character). Metacharacter "x" is also allowed: "x" means any byte value
in that position is fine.
Also enter Position and Offset value in order to define
the position where to find the pattern in the layer 3
protocol message:
-‘Position’: choose either ‘From Start’ or ‘From
End’. ‘From Start’ position is the first byte in
the layer 3 protocol message, which is the
Protocol discriminator.
-‘Offset’: define the offset in bytes, regarding
the ‘Position’ chosen.
Note: Layer 3 Address (L3Address): It is used to uniquely reference a user port
or a common control function. In case of PSTN user port. This shall be a 15 bit
number. In case of an ISDN user port or a common control function, this shall be a
13 bit number. But the L3Address entered here is always a 16 bit number
composed by the 2 bytes which come after the protocol discriminator byte.
Note: in the ‘Bit pattern’ area, don’t leave blank lines between two bytes of
pattern.

Tools -> statistics

The statistics function enables the user to view the number
of occurrences of any message in Layer1, Layer2 and
Layer3 events. Within each window you can apply the
statistics count to the monitor, history buffer, or between
markers. Analysis can also displayed as a pie chart and
applied to any of the protocols such as PSTN, ISDN and
BCC protocols running within V5.
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Tools -> Traffic Monitor

The traffic monitor enables the user to view graphically the
average, maximum and current rate at which an event is
happening.

The Traffic monitor has a very intuitive user interface
but you can find here some tips about it:
•

Add as many charts as you want by choosing "Add
an element" from the "Edit" menu. For each
element, the chart shows the Maximum ("Max")
throughput, the global Average ("Av") throughput
since the element has been added, and the current
throughput ("Cur") which is an average value over
a time interval specified by yourself in the
element's properties.

•

To select a particular chart, just left-click it. The
information displayed in the status bar is relative to the
selected chart i.e. the "Elapsed time" over which the
Average value ("Av" bar) is computed, the "Time
Interval" over which the current value ("Cur" bar) is
computed, and the time when the last message in
concern arrived.

•

Get the properties of a particular chart by double
clicking on it. The properties are:
-The chart's Time Unit.
-The Time Interval. The instant value (the red bar
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in then screenshot) is calculated over this time
interval.

Setup -> Protocol selection

•

Start the Journal recording to save the values as
time pass. This will let you create, with Microsoft
Excel for instance, a time historical chart.

•

Choose "File \ Exit" to close the Traffic Monitor, if
you DON'T want to continue monitoring the traffic
(as a background task); otherwise choose "File \
Hide" or click on the upper-right hand icon to
close the window.

Protocol selection should be set to V5.1 & V5.2
protocol

Setup -> configuration

This function sets the V5analyser to be configured to a
source.
It has three function s
1. Server settings
For use with the Emutel windows application the
sever settings should be set to local.
2. Capture
This function sets record file and history buffer
size. It also enables the user to set the buffer to
wrap or stop recording when full.
3. Source
Source will automatically display the current Cchannels that are available from the Emutel
Virtuoso

Setup -> filters

Filters can be applied to reduce the amount of
information displayed to the user. This can be achieved
by two methods
1. Suppress/ include selected messages
2. Suppress/include Layer3 address
The filters can be applied by selecting the active button
on the filter window. The filter can be applied for
Layer1,Layer2, and Layer3 messages.
The filters can be applied
-To an existing trace, Setup ->filters->display.
-to a record file , Setup ->filters->record.
-to a history buffer, Setup ->filters->history buffer
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1 Message Filter
Important:
with the V5 protocol using ISDN port, you can have a
double layer filter: a filter for V5 protocol messages
and L3 address and another for ISDN messages and
Call Reference value.
Select the protocol messages to keep or to suppress
with the help of the arrow buttons.
Arrow buttons
Use the arrow buttons to move one or more message
from one list to the other.
·To move the entire message from one list into the
other click the double arrow buttons ( >> or << ).
·To move only the selected message or messages from
one list into the other, click the single arrow buttons (
> or < ).
2. L3Address or Call Reference Filter
V5 Protocol: Layer 3 Address (L3Address).
It is used to uniquely reference a user port or a
common control function. In case of PSTN user port.
This shall be a 15 bit number. In case of an ISDN user
port or a common control function, this shall be a 13
bit number. But the L3Address entered here is always
a 16 bit number composed by the 2 bytes, which come
after the protocol discriminator byte.
Enter the L3Addresses in hexadecimal value and then
choose if you want either to exclude or to include only
those L3 addresses.
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ISDN Protocol: Call Reference Value.
It is used to identify the call request at the local usernetwork interface to which the particular message
applies. The Call Reference value must be entered in
decimal value.

Setup -> Display modes

The display modes function allows the user to set the
format of the messages that are displayed in the
window. This enables the user to set the decoding for
each layer
Layer 1 – ON\OFF or ALARM ONLY
Layer 2 – OFF\HEX\SHORT\COMPLETE
Layer 3 - OFF\HEX\SHORT\Identified\identified +
values\COMPLETE
The colors Tag enable the user to change the color
combinations of messages. The colors of the messages
can be customized to suite the user

Setup -> save setting on exit
Setup ->save settings now
Windows -> New

Help->online help

Help ->V5 protocol guide

This will save any new setting to the setup
configuration on exiting the V5analyser
Saves and setup changes on selection.
Enables the user to view a current display in another
window. This means the user can have a different
display method in the second window. Both windows
will scroll together. This ensure that both trace decodes
are at the same point in the current trace.
Shortcut Key (Ctrl + W)
The online help will enable the user to obtain
explanations of the functions shown above. This path
may need to be initially set. When selecting the online
help function the V5analyser may display an error
message in finding the help files. From this error
message select browse to find the required files on
your computers hard disk.
The V5 protocol guide help gives the user a general
description of the V5 messages defined in ETS 300
324 and ETS 300-347
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PORT

TELEPHONE NUMBER

V5BRI1
V5BRI2
V5BRI3
V5BRI4
V5BRI5
V5BRI6
V5BRI7
V5BRI8
V5BRI9
V5BRI10
V5BRI11
V5BRI12
V5BRI13
V5BRI14
V5BRI15

385000
385020
385040
385060
385080
385100
385120
385140
385160
385180
385200
385220
385240
385260
385280
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PORT

TELEPHONE NUMBER

V5PSTN1
V5PSTN2
V5PSTN3
V5PSTN4
V5PSTN5
V5PSTN6
V5PSTN7
V5PSTN8
V5PSTN9
V5PSTN10
V5PSTN11
V5PSTN12
V5PSTN13
V5PSTN14
V5PSTN15
V5PSTN16
V5PSTN17
V5PSTN18
V5PSTN19
V5PSTN20
V5PSTN21
V5PSTN22
V5PSTN23
V5PSTN24
V5PSTN25
V5PSTN26
V5PSTN27
V5PSTN28
V5PSTN29
V5PSTN30
V5PSTN31
V5PSTN32
V5PSTN33
V5PSTN34
V5PSTN35
V5PSTN36
V5PSTN37
V5PSTN38
V5PSTN39
V5PSTN40
V5PSTN41
V5PSTN42
V5PSTN43
V5PSTN44
V5PSTN45

380001
380002
380003
380004
380005
380006
380007
380008
380009
380010
380011
380012
380013
380014
380015
380016
380017
380018
380019
380020
380021
380022
380023
380024
380025
380026
380027
380028
380029
380030
380031
380032
380033
380034
380035
380036
380037
380038
380039
380040
380041
380042
380043
380044
380045
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PORT

TELEPHONE NUMBER

V5PSTN47
V5PSTN48
V5PSTN49
V5PSTN50
V5PSTN51
V5PSTN52
V5PSTN53
V5PSTN54
V5PSTN55
V5PSTN56
V5PSTN57
V5PSTN58
V5PSTN59
V5PSTN60

380047
380048
380049
380050
380051
380052
380053
380054
380055
380056
380057
380058
380059
380060

Appendix I

38

ISDN INTERFACE PINOUTS

PORT

TELEPHONE NUMBER

V5 EMUTEL BRI1
V5 EMUTEL BRI 2
V5 EMUTEL BRI 3
V5 EMUTEL BRI 4
V5 EMUTEL BRI 5
V5 EMUTEL BRI 6
V5 EMUTEL BRI 7
V5 EMUTEL BRI 8

384700
384720
384740
384760
384780
380800
380820
380840
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ISDN interface Pin-outs

The following table shows the pin-outs of the RJ45
connectors for the ISDN interfaces.

1
2
3
4
5
6
7
8

PRI 1
E1 or
T1
RR+
NC
TT+
NC
NC
NC

Appendix II

PRI 2
E1 or
T1
TT+
NC
RR+
NC
NC
NC

BRI
S

U

NC
NC
RTT+
R+
NC
NC

NC
NC
NC
RING
TIP
NC
NC
NC
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